keywords: ip pbx voip gateway gsm gateway

× Questions about B100/200/400/800 ISDN BRI Cards

Problems with B100P in NT mode & Elastix

10 years 11 months ago #5916 by spyros
Hi. I recently bought a B100P card and use it with Elastix. I want to connect a simple ISDN phone on the card so I've setup jumpers (SW1 to the left & SW2=ON) and misdn-init, mISDN, and misdn files to NT mode ptmp. The card is recognized by elastix but I have no tone from the phone. When I do misdn show stacks I get:

misdn show stacks
* Port 1 Type NT Prot. PMP L2Link DOWN L1Link:UP Blocked:0 Debug:0
I have followed every guide available online but this have given me only headaches without any result.

I would appreciate your help.

Kind regards,

i] Last edited by spyros at 2010-7-16 02:18 [/i
10 years 11 months ago #5917 by spyros
I also get under hardware detection:

Port 1: NT-mode BRI S/T interface port (for phones)
-> Layer 2 protocol 0x02000002 is detected, but not allowed for NT lib.
* Port NOT useable for PBX (maybe there is already a PBX running?)

Furthermore I have created a custom extension for the phone and in PBX-extension properties under "This device uses custom telephony" I direct it to mISDN/1.
Is this correct?

The telephone I am connecting is a plain ISND phone through a simple straight UTP cable to the card.

Thanks in advance,

i] Last edited by spyros at 2010-7-16 02:17 [/i
10 years 11 months ago #5922 by Denins.Den
Please send your SSH to me
10 years 11 months ago #5924 by james.zhu
to use the NT mode, the power supply must given from external or internal device.

10 years 11 months ago #5925 by Denins.Den
Did your ISDN phone have it own power supply? If no, you can't use B100P with this isdn phone in NT mode.
10 years 11 months ago #5926 by spyros
thank you for your prompt replies.

The ISDN phone I am using is a DECT phone and has it's own power supply. Well I have tried everything to forward the SSH port to my router, disabled firewall, setup dyndns etc but when I try to connect from the outside it says "connection denied". Even tried to change the ports through httpd but still nothing. It is merely impossible to connect from the outside. It just refuses every connection. Do you think it is a router problem or Elastix has some kind of feature to refuse connections from the outside?

After playing a bit with every single guide I could find online I have managed to make the phone make calls (ISDN phone dials other extensions and outside line through 9 OK) but cannot accept calls. Any ideas here?

Time to create page: 0.040 seconds
Powered by Kunena Forum