keywords:pbx ip pbx voip gateway gsm gateway

× Questions about B100/200/400/800 ISDN BRI Cards

problem openvox b100p and misdn intallation

9 years 4 days ago #6158 by tonyalfa821
hi i have a bri card openVox b100p and trixbox 2.8 for install the driver i have used this guide:

yum –y install kernel-smp-devel, be sure the version of kernel, if system kernel is without smp, please run this:
yum –y install kernel-devel
wget http://www.beronet.com/downloads/instal ... eue.tar.gz
tar xzf install-misdn-mqueue.tar.gz
cd install-misdn-mqueue
make
make install


But if i digit MAKE i have 2 errors:

/usr/bin/ld: cannot find -lncurses
collect2: ld returned 1 exit status
make[3]: *** [voipisdn] Error 1
make[3]: Leaving directory `/root/install-misdn-mqueue/mISDNuser-1_1_9.1/voip'
make[2]: *** [subdirs] Error 2
make[2]: Leaving directory `/root/install-misdn-mqueue/mISDNuser-1_1_9.1'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/root/install-misdn-mqueue/mISDNuser-1_1_9.1'
make: *** [mISDNuser-1_1_9.1] Error 2


please help
where is my error..???
tnx
Antonio

i] Last edited by tonyalfa821 at 2010-9-12 19:42 [/i
9 years 4 days ago #6161 by Joe.Yung
Hi,It seems that you didn't YUM install these two packages: ********************************
yum install ncurses
yum install ncurses-devel
********************************

Make sure you have already installed these packages before you do anything. Execute this command below.

yum -y install bison bison-devel ncurses ncurses-devel zlib zlib-devel openssl opessl-devel gnults-devel gcc gcc++

After that, please try it again!

i] Last edited by Joe.Yung at 2010-9-13 09:29 [/i

9 years 1 day ago #6180 by tonyalfa821
hi joe


sorry for the delay
now i try the your solution.....

in the meantime.... you think it can be a hardware problem???......

by
Antonio
9 years 1 day ago #6182 by tonyalfa821
hi joe

i have try your solution but when i try the command

yum -y --enablerepo=trixboxbeta install asterisk-chan_misdn


have


asterisk-chan_misdn-1.4.22-3.i386 from trixbox has depsolving problems
--> Missing Dependency: libsuppserv.so.0 is needed by package asterisk-chan_misdn-1.4.22-3.i386 (trixbox)
Error: Missing Dependency: libisdnnet.so.0 is needed by package asterisk-chan_misdn-1.4.22-3.i386 (trixbox)
Error: Missing Dependency: libmISDN.so.0 is needed by package asterisk-chan_misdn-1.4.22-3.i386 (trixbox)
Error: Missing Dependency: libsuppserv.so.0 is needed by package asterisk-chan_misdn-1.4.22-3.i386 (trixbox)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.






you have a idea???!!!!
9 years 1 day ago #6187 by Joe.Yung
Hi,
It seems that your system still lacks of some other dependency packages, something like lib*.

Please choose and install the missing packages which match with your own server from here:
http://yum.trixbox.org/centos/5/RPMS/

According to the system prompts and install what it needs.

8 years 11 months ago #6201 by tonyalfa821
nothing to do....

now i would try the verion of trixbox 2.6....

it's a good idea for you??

:(
Time to create page: 0.023 seconds
Powered by Kunena Forum