× Questions about B100/200/400/800 ISDN BRI Cards

Choppy IVR sound on two inbound calls through B100P

7 years 8 months ago #7367 by Kraftway
Hi all,

There are two ISDN lines so I use two OpenVox B100P cards installed in Asterisk host, both ports are set as TE mode. The Asterisk system has an IVR configured. When the IVR answers on two simultaneous inbound external calls through ISDN cards its sound becomes very choppy. As soon as one call is finished the IVR sound becomes clear immediately. When I asked the question regarding this trouble on the russian forum, I've got an answer that it may be caused by absence of sync (some timing issue?), and the solution of this problem is very complicated. And there were nobody who can help me to resolve the problem :(

The PC is the hardware platform, not any Virtual Machine.
OS: Debian GNU/Linux 6.0.2.1 Squeeze
Kernel: 2.6.32-5-686
Asterisk: Asterisk 1.6.2.9-2+squeeze3
UI: FreePBX 2.9.0.7
mISDN: Modular ISDN core version 1.1.21

#dmesg
cut
[ 5.205367] mISDN_hfcpci: found adapter CCD/Billion/Asuscom 2BD0 at 0000:00:0a.0
[ 5.205376] mISDN: HFC-PCI driver 2.0
[ 5.205518] HFC-PCI: defined at mem 0xe0c00000 fifo 0xdf190000(0x1f190000) IRQ 18 HZ 250
[ 5.205994] HFC 1 cards installed
[ 5.206071] hfcpci 0000:00:0b.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
[ 5.206079] mISDN_hfcpci: found adapter CCD/Billion/Asuscom 2BD0 at 0000:00:0b.0
[ 5.206088] mISDN: HFC-PCI driver 2.0
[ 5.206212] HFC-PCI: defined at mem 0xe0c04000 fifo 0xdf198000(0x1f198000) IRQ 19 HZ 250
[ 5.206640] HFC 2 cards installed
cut

#lcr query
** LCR Version 1.7
-> Using 'misdn_info'
Found 2 ports
Port 0 'hfc-pci.1': TE/NT-mode BRI S/T (for phone lines & phones)
2 B-channels: 1-2
B-protocols: RAW HDLC X75slp L2: DSP L2: DSPHDLC
Port 1 'hfc-pci.2': TE/NT-mode BRI S/T (for phone lines & phones)
2 B-channels: 1-2
B-protocols: RAW HDLC X75slp L2: DSP L2: DSPHDLC

#cat /etc/lcr/interface.conf
[ext5030]
portnum 0
layer2hold yes

[ext5046]
portnum 1
layer2hold yes

pbx*CLI> module show like timing
Module Description Use Count
res_timing_pthread.so pthread Timing Interface 0
res_timing_dahdi.so DAHDI Timing Interface 0
res_timing_timerfd.so Timerfd Timing Interface 1

Can anybody help me? I am looking forward to your help.
Thank you!

Leonid
7 years 8 months ago #7368 by tim.june
Hi, Leonid

Please provide your ssh, I need check your system to reason out what the problem is.
My email: This email address is being protected from spambots. You need JavaScript enabled to view it.
MSN: This email address is being protected from spambots. You need JavaScript enabled to view it.

Email: This email address is being protected from spambots. You need JavaScript enabled to view it.
Skype: tim.jjune
Time to create page: 0.027 seconds
Powered by Kunena Forum