keywords:pbx ip pbx voip gateway gsm gateway

× Questions about B100/200/400/800 ISDN BRI Cards

B200: how to setting NT mode

11 years 5 months ago #835 by fightfight
hi, i have a b200 card installed.
the NT/TE Settings of S/T 2 is change to NT
and the Termination of S/T 2 is change to Connect
and the Power feeding connector is change to connect
then:
run misdn-init scan
[OK] found the following devices:
card=1,0x4
[ii] run "/usr/sbin/misdn-init config" to store this information to /etc/misdn-init.conf

run misdn-init config
[OK] /etc/misdn-init.conf already present. backing it up to /etc/misdn-init.conf.save
[OK] /etc/misdn-init.conf created. It's now safe to run "/usr/sbin/misdn-init start"
[ii] make your ports (1-4) available in asterisk by editing "/etc/asterisk/misdn.conf"

run misdnportinfo

Port 1: TE-mode BRI S/T interface line (for phone lines)
-> Protocol: DSS1 (Euro ISDN)
-> Layer 4 protocol 0x04000001 is detected, but not allowed for TE lib.
-> childcnt: 2
* Port NOT useable for PBX (maybe there is already a PBX running?)
Port 2: TE-mode BRI S/T interface line (for phone lines)
-> Protocol: DSS1 (Euro ISDN)
-> Layer 4 protocol 0x04000001 is detected, but not allowed for TE lib.
-> childcnt: 2
* Port NOT useable for PBX (maybe there is already a PBX running?)

the auto-general /etc/misdn.conf is always
te_ptmp=1,2,3,4
i change it to
te_ptmp=1,2
nt_ptmp=3,4
but get the same result. why ?
11 years 5 months ago #837 by james.zhu
hello, fightfight:
could you show me the lspci -vvvvvv result? if the pciid is e888, i think you have to manually edit he mISDN.conf file and load the module. you can refer the link:
www.openvox.com.cn/bbs/viewtopic.php?t=301 .
Regards,
James.zhu

11 years 5 months ago #838 by fightfight
yes, the lspci is e888, and now when i set
<mISDNconf>
<module poll="128" debug="0" timer="no">hfcmulti</module>
<module debug="0" options="0">mISDN_dsp</module>
<devnode user="root" group="root" mode="644">mISDN</devnode>
<card type="BN2S0">
<port mode="te" link="ptmp">1</port>
<port mode="nt" link="ptmp">2</port>
</card>
</mISDNconf>

in asterisk:
asterisk1*CLI> misdn show stacks
BEGIN STACK_LIST:
* Port 1 Type TE Prot. PMP L2Link DOWN L1Link:DOWN Blocked:0 Debug:4
* Port 2 Type NT Prot. PMP L2Link DOWN L1Link:DOWN Blocked:0 Debug:4

the port type change to NT is sucessed, but the link is down.
the port 1 and port 2 is connect by a rj-45 cross-line
RJ-45 Pin (TE side) RJ-45Pin (NT side)
J1-3 J2-4
J1-4 J2-3
J1-5 J2-6
J1-6 J2-5

how can i made it work?
11 years 5 months ago #839 by james.zhu
hello, Sir:
please check it:
<port mode="te" link="ptmp">1</port>
<port mode="nt" link="ptmp">2</port>, it can not be ptmp, it should be ptp, right? please check that. how to you load the modules? if you load the modules from modprobe hfc such as:
modprobe hfcmulti type=0x2 .... poll=64 debug=0
please check that from this website:
misdn.org/index.php/Configuring_mISDN . it has more details for that.
if you still have problem, please email me at:james.zhu@openvox.cn
Regards,
James.zhu

Time to create page: 0.025 seconds
Powered by Kunena Forum