keywords:pbx ip pbx voip gateway gsm gateway

× Questions about B100/200/400/800 ISDN BRI Cards

patch for OpenVox b200p/b400p/b800p for bristuff-0.4.0-test6

11 years 6 months ago #930 by james.zhu
hello, all of users:
if you want to use bristuff-0.4.0-test6 for OpenVox bri cards, please download the file and replace the original qozap.c with new qozap.c download from here. i test it for B200P/B400P/B800P, all cards are work under it. before compiling it, you have to make sure that apply-patches.sh for qozap is done properly.
Regards!
James.zhu

Attachments:
11 years 5 months ago #990 by menno
i'd like to test it, but there seems to be no attachment, where can i find the new version?

also, is there any plans to get this integrated upstream? i tried a diff on qozap.c and the one from bristuff but i get the feeling it's almost a complete re-write ?

[edit] sorry, after writing this message i do see the attachment now.
11 years 4 months ago #1088 by davidmh
Does this patch work with bristuff 0.4 RC1 ?
11 years 4 months ago #1089 by james.zhu
hi:
i do not test that under RC1. But I think it should work under RC1.
Regards!
James.zhu

11 years 4 months ago #1090 by marcuswrk
I'm unable to compile bristuff on Fedora Core 8 kernel 2.6.23.1-42.fc8

I followed the instrunction as openvox manual
- replace bristuff-0.4.0-test6/qozap/qozap.c
- run install.sh

I’m getting error compiling cwain.c, unable to continue.
patching file cwain.c
1 out of 1 hunk FAILED -- saving rejects to file qozap.c.rej
Failed applying /root/bristuff-0.4.0-test6/patches/qozap/100-local_zap.diff (directory: patches/qozap). Aborting.

Same error on RC1

Need help
11 years 4 months ago #1091 by james.zhu
hello,
i think the file is conflict with the diff files. please try to run the system in this way in the install.sh:

#!/bin/sh

set -e

./download.sh // download the source code and patch for system
cp qozap.c get from website and replace it with original file. this is what you replace.
./compile.sh // compile it
if you check the download.sh, you will find that the system patch first, there are the error caused.
regards!
James.zhu

Time to create page: 0.024 seconds
Powered by Kunena Forum