keywords:pbx ip pbx voip gateway gsm gateway

× Questions about B100/200/400/800 ISDN BRI Cards

Help on B400P, mIsdn and Zaptel

11 years 4 months ago #1098 by andreafi
Please, help me on this problem.

I have a work installed asterisk with Openvox A400P and Zaptel driver configured.
I just bought an B400P to add it on my asterisk and as soon as I install mIsdn, the zaptel stop to work (but work mIsdn and the B400P card).

I get these two errors during the boot:

loading zaptel hardware modules: no functioning zap hardware found in /proc/zaptel, loading ztdummy

running ztfg: ztcfg: ZT_CHANCONFIG failed on channel 2: No such device or address (6)

If I run this command after the boot:

modprobe wctdm

the module is loaded normally and after an amportal restart, everithing works again.


This is the script I used to install mIsdn:

yum -y update
yum -y install kernel-smp-devel (oppure kernel-devel)
reboot
cd /usr/src
wget www.misdn.org/downloads/releases/mISDN-1_1_7_2.tar.gz
tar -xzvf install-misdn-mqueue.tar.gz
cd install-misdn-mqueue
make
make install
reboot
/etc/init.d/misdn-init scan
/etc/init.d/misdn-init config
/etc/init.d/misdn-init start

Thanks.

Andrea
11 years 4 months ago #1099 by miaolin
you have to modify your zaptel.conf so that system can load module correctly.

for mISDN config, please look into manual as reference.
11 years 4 months ago #1100 by andreafi
Thanks for your reply.

The file /etc/zaptel.conf is right configured.
The problem seem to be during the loading of the zaptel hardware modules, because it's say the "no functioning zap hardware found in /proc/zaptel".
The mIsdn works well.
But the problem on zaptel start just after the installation of mIsdn.

This is my zaptel.conf:

# Autogenerated by /usr/local/sbin/genzaptelconf -- do not hand edit
# Zaptel Configuration File
#
# This file is parsed by the Zaptel Configurator, ztcfg
#

# It must be in the module loading order


# Span 1: WCTDM/0 "Wildcard TDM400P REV E/F Board 1" (MASTER)
# channel 3, WCTDM, inactive.
# channel 4, WCTDM, inactive.
fxoks=1
fxsks=2


# Span 2: ZTDUMMY/1 "ZTDUMMY/1 (source: Linux26) 1"

# Global data

loadzone = us
defaultzone = us
11 years 4 months ago #1101 by miaolin
please mail me your ssh root account.
This email address is being protected from spambots. You need JavaScript enabled to view it.
11 years 3 months ago #1105 by andreafi
I solved the problem by inserting in the rc.local file the command:

modprobe wctdm

During the boot I get the error, but after the boot and before running asterisk the modprobe load the card driver and everithing works well.

Thanks to Miaolin for the help.

Andrew
Time to create page: 0.026 seconds
Powered by Kunena Forum