keywords:pbx ip pbx voip gateway gsm gateway

× Questions about B100/200/400/800 ISDN BRI Cards

CAPI_REGISTER failed - CAPI not installed (0x1009) [No such device or address (6

9 years 11 months ago #4158 by arif.zaman
Hi All,

I would also like to be able to use the system to establish a 128k(possibly 256k multilink) PPP connection to an ISP who supports 128k(2B's) or 256k (4B's) connection. For this, I have installed thefollowing packages:
- mISDNuser-1_1_9.1
- mISDN-1_1_9.1
- ppp-2.4.4
- capi4k-utils-2005-07-18

I have done the followings:
$ uname -r
2.6.18-128.1.10.el5

$ lspci -v
02:01.0 ISDN controller: Cologne Chip Designs GmbH ISDN network Controller [HFC-4S] (rev 01)
Subsystem: Cologne Chip Designs GmbH ISDN network Controller [HFC-4S]
Flags: medium devsel, IRQ 177
I/O ports at c880 [\size=8]
Memory at cfbfe000 (32-bit, non-prefetchable) [disabled] [size=4K]
Capabilities: [40] Power Management version 2

$ mISDN scan
1 mISDN compatible device(s) found:
>> BN4S0

$ mISDN config
Writing /etc/mISDN.conf for 1 mISDN compatible device(s):
>> BN4S0
/etc/mISDN.conf already present, saving a backup: /etc/mISDN.conf.bak

$ mISDN start
-- Loading mISDN modules --
>> /sbin/modprobe --ignore-install capi
>> /sbin/modprobe --ignore-install mISDN_core debug=0
>> /sbin/modprobe --ignore-install mISDN_l1 debug=0
>> /sbin/modprobe --ignore-install mISDN_l2 debug=0
>> /sbin/modprobe --ignore-install l3udss1 debug=0
>> /sbin/modprobe --ignore-install mISDN_capi
>> /sbin/modprobe --ignore-install hfcmulti type=0x4protocol=0x2,0x2,0x2,0x2 layermask=0xf,0xf,0xf,0xf poll=128 debug=0timer=0
>> /sbin/modprobe --ignore-install mISDN_dsp debug=0 options=0

$ misdnportinfo
Port 1: TE-mode BRI S/T interface line (for phone lines)
-> Protocol: DSS1 (Euro ISDN)
-> childcnt: 2

[/font]
Port 2: TE-mode BRI S/T interface line (for phone lines)
-> Protocol: DSS1 (Euro ISDN)
-> childcnt: 2

[/font]
Port 3: TE-mode BRI S/T interface line (for phone lines)
-> Protocol: DSS1 (Euro ISDN)
-> childcnt: 2

[/font]
Port 4: TE-mode BRI S/T interface line (for phone lines)
-> Protocol: DSS1 (Euro ISDN)
-> childcnt: 2

[/font]
mISDN_close: fid(3) isize(131072) inbuf(0x8b40060) irp(0x8b40060) iend(0x8b40060)

$ lsmod
Module Size Used by
mISDN_dsp 196200 0
hfcmulti 73452 0
mISDN_capi 93516 0
l3udss1 40836 0
mISDN_l2 38780 0
mISDN_l1 15332 0
mISDN_core 78848 6 mISDN_dsp,hfcmulti,mISDN_capi,l3udss1,mISDN_l2,mISDN_l1
capi 20865 0
capidrv 30453 0
isdn 122305 1 capidrv
kernelcapi 48705 3 mISDN_capi,capi,capidrv
capifs 9801 2 capi
[... snipped other Module entries ...]

$ tail -f /var/log/messages
mISDN: HFC-multi driver Rev. 1.68
HFC-multi: card manufacturer: 'Cologne Chip AG' card name: 'HFC-4S CCAG Eval (old)' clock: normal
PCI: Enabling device 0000:02:01.0 (0000 -> 0003)
ACPI: PCI Interrupt 0000:02:01.0[A] -> GSI 17 (level, low) -> IRQ 177
HFC-4S#1: defined at IOBASE 0xc880 IRQ 177 HZ 1000 leds-type 0
HFC_multi: resetting HFC with chip ID=0xc revision=1
hfcpci_probe: DIPs(0x0) jumpers(0x0)
1 devices registered
mISDN_dsp: Audio DSP Rev. 1.29 (debug=0x0) EchoCancellor MG2 dtmfthreshold(100)
mISDN_dsp: DSP clocks every 64 samples. This equals 8 jiffies.

$ sh /usr/src/capi4k-utils/scripts/makedev.sh

$ ls -al /dev/capi*
crw-rw-rw- 1 root root 68, 0 Nov 11 08:03 /dev/capi20

/dev/capi:
total 0
drwxr-xr-x 2 root root 0 Nov 4 20:44 .
drwxr-xr-x 12 root root 3640 Nov 11 08:03 ..

$ cat /etc/ppp/peers/isdn/arcor
sync
noauth
user <username>
plugin userpass.so
password <password>
defaultroute
plugin capiplugin.so
number <ISP-PHONE-NUMER>
protocol hdlc
ipcp-accept-local
ipcp-accept-remote
/dev/null

$ pppd call isdn/arcor
Plugin userpass.so loaded.
userpass: $Revision: 1.5 $
Plugin capiplugin.so loaded.
capiplugin: $Revision: 1.36 $
capiconn: 1.13
[/size] capiplugin: CAPI_REGISTER failed - CAPI not installed (0x1009) [No such device or address (6)]

Now, i'm getting
RED marked error message. Can you please point me where I'm doing wrong?

Please help me with your valuable feedback.

Thanks,
ARIF


i] Last edited by arif.zaman at 2009-11-12 14:01 [/i
9 years 11 months ago #4159 by james.zhu
hello:
your CAPI could be created, please check your capi.

9 years 11 months ago #4160 by arif.zaman
Thanks for your quick response!

Original posted by [/font]james.zhu at 2009-11-12 14:30


hello:
your CAPI could be created, please check your capi.

[/font]
[/size]actually, i am a new-bie here. Can you please help me out to check the capi?

Thanks,
ARIF


9 years 11 months ago #4161 by arif.zaman
I found the following output for CAPI status:

$ /etc/init.d/capi start
Starting capi4linux: [ OK ]

$ /etc/init.d/capi status
capi not installed - No such device or address (6)

Please help me out!

Thanks,
ARIF

9 years 11 months ago #4162 by james.zhu
hi:
are you using OpenVox card? what is this:
=====================
HFC-multi: card manufacturer: 'Cologne Chip AG' card name: 'HFC-4S CCAG Eval (old)' clock: normal
========================
it should show "OpenVox" there.
I do not test capi4linux, i am not very sure that. maybe some other modules are conflicted with this modules. anyway, you can give me the ssh to check that. my email: This email address is being protected from spambots. You need JavaScript enabled to view it.
regards!
James.zhu

9 years 11 months ago #4180 by arif.zaman
Solved!

Thanks for all your time and support!

- ARIF
Time to create page: 0.038 seconds
Powered by Kunena Forum