keywords: ip pbx voip gateway gsm gateway

× Questions about D110/210/410 T1/E1/J1 PRI Cards

Voice quality of DE410P x 2 in dual Xeon 2.66G

11 years 5 months ago #3675 by gd5gd
As title, when number of call made is greater than 70, the voice quality is intermittent. CPU loading is only around 40% and I/O allocation are as follows:

CPU0 CPU1 CPU2 CPU3
0: 261149557 0 0 0 IO-APIC-edge timer
1: 3 0 0 0 IO-APIC-edge i8042
6: 2 0 0 0 IO-APIC-edge floppy
8: 1 0 0 0 IO-APIC-edge rtc
9: 1 0 0 0 IO-APIC-level acpi
12: 4 0 0 0 IO-APIC-edge i8042
14: 664259 0 0 0 IO-APIC-edge ide0
15: 2974141 0 0 0 IO-APIC-edge ide1
177: 31 0 155035554 0 IO-APIC-level eth0
193: 34962 260871372 0 0 IO-APIC-level wct4xxp
201: 29156 0 0 260967195 IO-APIC-level wct4xxp
NMI: 0 0 0 0
LOC: 261158069 261127575 261159986 261159984

I have already separated ethernet card and 2 DE410P, but nothing improve.
How can I improve it?

Many thanks

11 years 5 months ago #3676 by james.zhu
11 years 5 months ago #3677 by gd5gd
All methods in your link I tried such as disable unused IRQ, assign individual IRQ to different DE410P, dedicate different interrupts to different CPU. However, quality only a little improve when number of call is large.

Any further idea

Thanks a lot
11 years 5 months ago #3678 by Robert
hello:
i have some tips ,please have a try
If you are running an IDE hard drive please verify that you are using DMA mode with a UDMA setting of no lower than 2 or higher than 3. UDMA mode 2 is ATA33. UDMA mode 3 is ATA44. This can be done using hdparm.

We suggest using "hdparm -d 1 -X udma2 -c 3 /dev/[IDE Device]". You can check the status using "hdparm /dev/[IDE Device]" and "hdparm -i /dev/[IDE Device]". If you make modifications to your IDE hard drive settings they will only be kept until you reboot. "

Be sure to try kernel 2.6 too, it has better I/O performance than 2.4 kernels.

Don't use X on your asterisk server.!
-Disable the framebuffer.
11 years 5 months ago #3680 by gd5gd
Thank you very much for your suggestion. The only thing I didn't try was hdparm. I will try it.

Thanks a lot
11 years 5 months ago #3682 by gd5gd
There is no improvement after I set /sbin/hdparm -d 1 -X udma5 -c 3 /dev/device and unplug one DE410P from the system. That means sound goes worse when number of call greater than around 60-70 at a same time. Any more suggestion? :'(:'(:'(

Thank you very much.
Time to create page: 0.049 seconds
Powered by Kunena Forum