keywords:pbx ip pbx voip gateway gsm gateway

× Questions about VS-GW2120/GW1600/GW1202 and WGW1002G GSM Series VoIP Gateway

VS-GGU-E2M0400 - Cloud PBX auth/proxy error

2 months 3 weeks ago #14178 by n.serafini95
Good evening,
I'm trying to configure the gateway in question to connect with UAC to a Cloud server that uses the proxy and outbound proxy method.

If I generate the generic autoprovisioning file for third-party devices from my PBX in cloud, I have these specifications:

User name / extension = 3359609600 // It's the user part of the "from:" field. Most often it's the pbx user extension
User name / authentication user name = 3359609600
Password / authenticate password = ****************
Local SIP port = 5617 // It's the UDP port used by the gateway for its account
Use Outbound Proxy = Yes // The usage of an outbound proxy cannot be avoided
Outbound Proxy Server = 217.61.28.69 or 217.61.28.69:5617
Outbound Proxy Port = 5617
Domain = irs.ucloud
Registrar / Proxy server = irs.ucloud or irs.ucloud: 5617
Registrar / Proxy server port = 5617
Registration Expire Time = from 60 to 120
Packet size / Ptime = 20 ms

and this is the asterisk configuration (gw_endpoints.conf) after creating an endpoint under the SIP-> Sip Endpoint section:

[3359609600]
username = 3359609600
registration = client
allow_anonymous = no
order = 3
secret = *******
host = 217.61.28.69
transport = udp
nat = yes
auth = 3359609600
register_extension = 3359609600
fromdomain = irs.ucloud
port = 5617
qualify = no
qualifyfreq = 60
dtmfmode = rfc2833
trustrpid = no
sendrpid = no
callingpres = allowed_passed_screen
progressinband = never
usereqphone = no
use_q850_reason = no
honorsdpversion = yes
allowtransfer = yes
promiscredir = no
max_forwards = 70
registertrying = no
outboundproxy = 217.61.28.69: 5617
timert1 = 500
timerb = 32000
session-timers = accept
session-minse = 90
session-expires = 120
session-refresher = uac
register => 3359609600: ***********: This email address is being protected from spambots. You need JavaScript enabled to view it.: 5617/3359609600
insecure = port, invite
type = friend
context = 3359609600

For me the problem is in the proxy server configuration in openvox sip client but I can't understand where to set this parameter on the SIP Endpoint configuration of openvox; I suppose below the field: 'Hostname or IP Address:' (in the html interface) which in the above configuration file corresponds to: 'host' (gw_endpoints.conf)

If in the value just described I insert the IP address of the proxy there is an effective exchange of SIP requests:
registar client -> Server
server trying -> client
server 488 -> client

Example of registering that I receive on the cloud server with the setting above:
REGISTER sip: 217.61.28.69: 5617 SIP / 2.0
Via: SIP / 2.0 / UDP 192.168.10.14:5060;branch=z9hG4bK60ae74ce;rport
From: <sip: This email address is being protected from spambots. You need JavaScript enabled to view it.>; tag = as514cd9ff
To: <sip: This email address is being protected from spambots. You need JavaScript enabled to view it.>
Call-ID: This email address is being protected from spambots. You need JavaScript enabled to view it.
CSeq: 102 REGISTER
Max-Forwards: 70
Contact: <sip: This email address is being protected from spambots. You need JavaScript enabled to view it.: 5060>
Expires: 120
User-Agent: VoxStack Wireless Gateway
Content-Length: 0

So the PBX in the Cloud, not recognizing the user, returns a 488 to client

So I thought of changing the host value ('Hostname or IP Address:' in html interface) with the irs.ucloud proxy domain (see general autoprovisioning file) but in this way not even the REGISTAR to my cloud server starts and in the contact there is an error bindings (the OpenVox gateway surfs the internet and the internal DNS work correctly (traceroute to FQDN ok)):

Retransmitting # 1 (NAT) to (null):
REGISTER sip: irs.ucloud SIP / 2.0
Via: SIP / 2.0 / UDP 0.0.0.0:5060;branch=z9hG4bK41f757d8;rport
Max-Forwards: 70
From: <sip: This email address is being protected from spambots. You need JavaScript enabled to view it.>; tag = as11d2a62c
To: <sip: This email address is being protected from spambots. You need JavaScript enabled to view it.>
Call-ID: This email address is being protected from spambots. You need JavaScript enabled to view it.
CSeq: 156 REGISTER
User-Agent: VoxStack Wireless Gateway
Expires: 120
Contact: <sip: This email address is being protected from spambots. You need JavaScript enabled to view it.: 5060>
Content-Length: 0

Finally, I repeat the openvox gateway specifications:
Model Name: VS-GGU-E2M0400
GSM Modem Description: GSM: 850/900/1800 / 1900MHz
Software Version: 2.0.7
Hardware Version: Date 2012-11-09 FPGA 11 Hardware 00


Do you think an OS update is needed?
Will I ever be able to register the openvox gateway via PROXY or is it not supported?
Can you tell me the correct configuration according to the autoprovisioning specifications extracted from my cloud server?


Thank you

Nicola
Attachments:
2 months 2 weeks ago #14203 by Echo
Hi, sir

1. please try to update the firmware to 2.5.2.
Here is the latest released firmware download address: www.openvox.cn/pub/firmwares/GSM%20Gateway/

PS: All versions must be updated to 2.2.2 first, so if your firmware version is lower than 2.2.2, pls do not try to skip 2.2.2 and update to latest version directly, it will fail!

Middle version: downloads.openvox.cn/pub/firmwares/GSM%2...ay/wg400-current.img (2.2.2)
Final version: downloads.openvox.cn/pub/firmwares/GSM%2...ay/wg400-current.bin (2.5.2)

2.The document in links can be used as a reference.

www.openvox.cn/pub/documents/other_docum...h_Elastix_Server.pdf

if any questions, you can add my skype:echo.yuan@openvox.cn.
2 months 1 week ago #14299 by n.serafini95
Hi everyone,
i has resolve whit firmware update at 2.5.2 version
Time to create page: 0.028 seconds
Powered by Kunena Forum