keywords: ip pbx voip gateway gsm gateway

× Questions about VS-GW2120/GW1600/GW1202 and WGW1002G GSM Series VoIP Gateway

SMS sending and receiving problem with SWG2008

2 months 1 week ago #15151 by kissze
Hello,

We have 3 SWG2008 devices and we are experiencing problems with the SMS sending and receiving.
Ww tested the sending and receiving functions yesterday and the result was that only 1 out of 3 sent messages are arrived. The msg status of the failed ones is SENT, the succesfully sent message status is DELIVERD.
Something similar happening with the receiving, we sent 4-5 messages from different mobile phones to the number in the system, but only 1 message appeared in the inbox.

We cannot find any log regarding the SMS system, and we stucked with this issue. We tried to upgrade one of our SWG device, but it didnt solved the issue.

Can somebody help us to go deeper in the debugging?

Thank you.

With kind regards,
Zoltan
2 months 4 days ago #15152 by hua
Hello

You can enter this in your browser to enable AT logs
http://172.16.210.1/cgi-bin/php/ajax_server.php?type=log&action=enable_astlog
make sure replace 172.16.210.1 to your gateway IP address , Then you can check the AT for SMS sending and receiving .
2 months 4 days ago #15158 by kissze
Hello,

we did some testing again according to your advises.

trying a proper number, receiving on the other end:
[Nov 24 13:55:21] DEBUG[1749] manager.c: Examining event:
Event: SMSStatusReport
Privilege: system,all
Board: 1
Channel: 1
MR: 93
Sender: +36xxxxxxxxxxx
SMSC: +36xxxxxxxxxxx
Time_scts: 2021/11/24 13:55:18
Timezone_scts: GMT+1
Status: SUCCESS
PDU: 07916302390090F9065D0B916302340083F6121142315581401211423155914000
IMSI: 216012094091023
Cause:0


trying a false number:
[Nov 24 13:56:20] DEBUG[1754] manager.c: Examining event:
Event: SMSSendStatus
Privilege: system,all
Board: 1
Channel: 1
MR: 93
Destination: +36xxxxxxxxxxxxxxxxxxxxxxxxx
ID: null
TXT: teszt
Status: FAIL
IMSI: 216012094091023


trying a proper number, but not receiving on the other end:

[Nov 24 13:58:04] DEBUG[1822] manager.c: Examining event:
Event: Newexten
Privilege: dialplan,all
Channel: EXTRA-SMS/1-1
Context: gsm-1
Extension: sms
Priority: 1
Application: NoOp
AppData: SMS In
Uniqueid: 1637758684.0

Also no error or fail message, no SMSSendStatus message or report.


worth to mention:
[Nov 24 12:25:29] ERROR[1734] res_timing_pthread.c: Error writing to timing pipe: Resource temporarily unavailable
[Nov 24 12:25:29] ERROR[1734] res_timing_pthread.c: Error writing to timing pipe: Resource temporarily unavailable
[Nov 24 12:25:29] ERROR[1734] res_timing_pthread.c: Error writing to timing pipe: Resource temporarily unavailable
[Nov 24 12:25:29] ERROR[1734] res_timing_pthread.c: Error writing to timing pipe: Resource temporarily unavailable
[Nov 24 12:25:29] ERROR[1734] res_timing_pthread.c: Error writing to timing pipe: Resource temporarily unavailable
[Nov 24 12:25:29] ERROR[1734] res_timing_pthread.c: Error writing to timing pipe: Resource temporarily unavailable
[Nov 24 12:25:29] ERROR[1734] res_timing_pthread.c: Error writing to timing pipe: Resource temporarily unavailable
[Nov 24 12:25:29] ERROR[1734] res_timing_pthread.c: Error writing to timing pipe: Resource temporarily unavailable
This is being constantly flooded into logs if we are not disabling ERROR logging manually.


The thing is that the system is not so reliable if it comes to the SMS messages. Maybe we can upgrade the modules itself or what can be the next step?


Thank you for your help.

With kind regards,
Zoltan
2 months 3 days ago #15160 by hua
Please follow my last topic and check the AT logs , succss AT and failed AT ,any different ?
2 months 2 days ago #15161 by kissze
The thing is that we cannot find any logs in the AT commands log section.
Maybe a GUI problem, can we read AT logs from CLI?

In the other hand if we trying to send SMS from the Web interface with the SMS Sender, then its not working. The status of those messages are always SENT, but we ddnt receiving those messages on our mobile phones.
If we are sending sms with the HTTP sender interface (IP:/sendsms?) then the SMS will be delivered to the phone and the status is DELIVERD on the SMS outbox interface.

So, something is definitely broken :)

Any other suggestion? I can say that ths s happening all of our 3 devices.

Cheers,
Zoltan
2 months 1 day ago #15162 by hua
Hello

You also need to enable AT logs under Logs setting . Then AT logs will show there , By the way you can add my skype upper.hua , I will check it for you remotely .
Time to create page: 0.038 seconds
Powered by Kunena Forum