keywords: ip pbx voip gateway gsm gateway

IPC 110c recognizing SATA as IDE problem

7 years 8 months ago #8864 by tripialos
Greetings
I have installed CentOS on a IPC 110c board with a 32GB Sandisk Solid State Disk drive.

After a couple of hours of operation we started receiving some strange messages
localhost kernel: hdc: no DRQ after issuing MULTWRITE_EXT
localhost kernel: ide1: reset: success
After googling around i found some people that had the same problem and the reason was because the motherboard sees the drive as an IDE and not as SATA.

http://www.centos.org/modules/newbb/viewtopic.php?topic_id=13125

They solved the problem by entering the BIOS and changing how the motherboard sees the drive, (*not IDE but AHCI)[font=Verdana, Arial, Helvetica, sans-serif][align=center]. [/align][/font]
[font=Verdana, Arial, Helvetica, sans-serif]
[/font]
[align=left]I tried to do the same on my IPC110c but i cant find in the BIOS any AHCI or any other option to change the config of the drive to sata.[/align]


[align=left]Any help would be much appriciated[/align]
[font=Verdana, Arial, Helvetica, sans-serif]
[/font]

i] Last edited by tripialos at 2013-6-12 16:52 [/i
7 years 8 months ago #8865 by tripialos
or at least could someone revert the support e-mail of openvox
7 years 8 months ago #8866 by chunlei.yi
hi,

pls try to solve your problem as the following way,if still have problem, you can contact me via skype or send email to me

1.Restore the BIOS settings to the factory default values.
2. Edit file /boot/grub/grub.conf and add parameters “all-generic-ide pci=nommconf” to the end of line “kernel/vmlinuz-xxx…”.
3.Execute command “hdparm –t /dev/hda” to check out the speed of disk, where hda is our test sample, you should accord to your real situation to properly modify.
4.This method is suitable to IDE, SATA, and Compact Flash Card.

skype: chunlei.yi
email: This email address is being protected from spambots. You need JavaScript enabled to view it.
7 years 8 months ago #8867 by tripialos
@chynlei.y





Thanks for your help. I will try it and revert back.
Time to create page: 0.031 seconds
Powered by Kunena Forum