keywords: ip pbx voip gateway gsm gateway

× Questions about A810/1610/2410 Advanced Analog Interface Card

Modprobe AE2410P Error

10 years 1 month ago #6425 by dveiga
I'm having a similar modprobe issue:

opvxa24xx: Unknown symbol dma_alloc_coherent
opvxa24xx: Unknown symbol _spin_unlock_irqrestore
opvxa24xx: Unknown symbol _spin_lock_irqsave
opvxa24xx: Unknown symbol malloc_sizes

The problem is a24xx.gcc4.x86_64.bin is compiled for older kernels. Does anybody know where the source code for this file is??

I'm planning to recompile it and post the new file. Of course the source code will need a few modifications, but this is solved using "#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 34)". This way the new code will work for both, new and old kernels. As not all changes in the kernel cause this type of error, a new file will not only work for this specific version, but might work for others too.

Bye,


Ing. Daniel A. Veiga
ADV Technology SRL
10 years 1 month ago #6443 by lisa.gao
Hi,
After you post here, we are committing ourselves to solve it. So sorry didn't feedback to you here. Support version will be released soon.

10 years 1 month ago #6444 by lisa.gao
Hi,
Now openvox-dahdi-linux-complete 2.3.0.1+2.3.0 and openvox-dahdi-linux-complete 2.4.0+2.4.0 can support kernel 2.6.34.
Now you can download the support version from: http://downloads.openvox.cn/pub/drivers/dahdi-linux-complete/

Time to create page: 0.036 seconds
Powered by Kunena Forum