× Questions about B100/200/400/800 ISDN BRI Cards

B400 and no audio on incoming call

8 years 1 month ago #7070 by gerapcik
Hi,

i have installed B400p with dahdi drivers on elastix 2.03.
i can make outgoing call, but i have some problems with incoming call.
here is my /etc/asterisk/dahdi-channels.conf
; Span 1: B4/0/1 "B4XXP (PCI) Card 0 Span 1" (MASTER) RED
group=0,11
context=from-pstn
switchtype = euroisdn
signalling = bri_cpe
channel => 1-2
context = default
group = 63

; Span 2: B4/0/2 "B4XXP (PCI) Card 0 Span 2" RED
group=0,12
context=from-pstn
switchtype = euroisdn
signalling = bri_cpe
channel => 4-5
context = default
group = 63

; Span 3: B4/0/3 "B4XXP (PCI) Card 0 Span 3" RED
group=0,13
context=from-pstn
switchtype = euroisdn
signalling = bri_cpe
channel => 7-8
context = default
group = 63

; Span 4: B4/0/4 "B4XXP (PCI) Card 0 Span 4"
group=0,14
context=from-pstn
switchtype = euroisdn
signalling = bri_cpe_ptmp
channel => 10-11
context = default
group = 63


line is connected to span 4. i had to set to bri_cpe_ptmp because on bri_cpe i had no incomming signal.
so when i make a call to this line on my cli i get:
== Spawn extension (macro-exten-vm, s-BUSY, 4) exited non-zero on 'DAHDI/10-1' in macro 'exten-vm'
== Spawn extension (from-did-direct, 84, 1) exited non-zero on 'DAHDI/10-1'
-- Hungup 'DAHDI/10-1'
-- Accepting call from '08119571057' to '8119571058' on channel 0/1, span 4
-- Executing [8119571058@from-pstn:1] NoOp("DAHDI/10-1", "Catch-All DID Match - Found 8119571058 - You probably want a DID for this.") in new stack
-- Executing [8119571058@from-pstn:2] Goto("DAHDI/10-1", "ext-did,s,1") in new stack
-- Goto (ext-did,s,1)
-- Executing [s@ext-did:1] Set("DAHDI/10-1", "__FROM_DID=s") in new stack
-- Executing [s@ext-did:2] Gosub("DAHDI/10-1", "app-blacklist-check,s,1") in new stack
-- Executing [s@app-blacklist-check:1] GotoIf("DAHDI/10-1", "0?blacklisted") in new stack
-- Executing [s@app-blacklist-check:2] Set("DAHDI/10-1", "CALLED_BLACKLIST=1") in new stack
-- Executing [s@app-blacklist-check:3] Return("DAHDI/10-1", "") in new stack
-- Executing [s@ext-did:3] ExecIf("DAHDI/10-1", "1 ?Set(CALLERID(name)=08119571057)") in new stack
-- Executing [s@ext-did:4] Set("DAHDI/10-1", "__CALLINGPRES_SV=allowed_not_screened") in new stack
-- Executing [s@ext-did:5] Set("DAHDI/10-1", "CALLERPRES()=allowed_not_screened") in new stack
-- Executing [s@ext-did:6] Goto("DAHDI/10-1", "from-did-direct,84,1") in new stack
-- Goto (from-did-direct,84,1)
-- Executing [84@from-did-direct:1] Macro("DAHDI/10-1", "exten-vm,novm,84") in new stack
-- Executing [s@macro-exten-vm:1] Macro("DAHDI/10-1", "user-callerid,") in new stack
-- Executing [s@macro-user-callerid:1] Set("DAHDI/10-1", "AMPUSER=08119571057") in new stack
-- Executing [s@macro-user-callerid:2] GotoIf("DAHDI/10-1", "0?report") in new stack
-- Executing [s@macro-user-callerid:3] ExecIf("DAHDI/10-1", "1?Set(REALCALLERIDNUM=08119571057)") in new stack
-- Executing [s@macro-user-callerid:4] Set("DAHDI/10-1", "AMPUSER=") in new stack
-- Executing [s@macro-user-callerid:5] Set("DAHDI/10-1", "AMPUSERCIDNAME=") in new stack
-- Executing [s@macro-user-callerid:6] GotoIf("DAHDI/10-1", "1?report") in new stack
-- Goto (macro-user-callerid,s,10)
-- Executing [s@macro-user-callerid:10] GotoIf("DAHDI/10-1", "0?continue") in new stack
-- Executing [s@macro-user-callerid:11] Set("DAHDI/10-1", "__TTL=64") in new stack
-- Executing [s@macro-user-callerid:12] GotoIf("DAHDI/10-1", "1?continue") in new stack
-- Goto (macro-user-callerid,s,19)
-- Executing [s@macro-user-callerid:19] NoOp("DAHDI/10-1", "Using CallerID "08119xxxxx" <08119xxxxxx>") in new stack
-- Executing [s@macro-exten-vm:2] Set("DAHDI/10-1", "RingGroupMethod=none") in new stack
-- Executing [s@macro-exten-vm:3] Set("DAHDI/10-1", "VMBOX=novm") in new stack
-- Executing [s@macro-exten-vm:4] Set("DAHDI/10-1", "EXTTOCALL=84") in new stack
-- Executing [s@macro-exten-vm:5] Set("DAHDI/10-1", "CFUEXT=") in new stack
-- Executing [s@macro-exten-vm:6] Set("DAHDI/10-1", "CFBEXT=") in new stack
-- Executing [s@macro-exten-vm:7] Set("DAHDI/10-1", "RT=""") in new stack
-- Executing [s@macro-exten-vm:8] Macro("DAHDI/10-1", "record-enable,84,IN") in new stack
-- Executing [s@macro-record-enable:1] GotoIf("DAHDI/10-1", "1?check") in new stack
-- Goto (macro-record-enable,s,4)
-- Executing [s@macro-record-enable:4] ExecIf("DAHDI/10-1", "0?MacroExit()") in new stack
-- Executing [s@macro-record-enable:5] GotoIf("DAHDI/10-1", "0?Group:OUT") in new stack
-- Goto (macro-record-enable,s,15)
-- Executing [s@macro-record-enable:15] GotoIf("DAHDI/10-1", "1?IN") in new stack
-- Goto (macro-record-enable,s,20)
-- Executing [s@macro-record-enable:20] ExecIf("DAHDI/10-1", "1?MacroExit()") in new stack
-- Executing [s@macro-exten-vm:9] Macro("DAHDI/10-1", "dial,,tm,84") in new stack
-- Executing [s@macro-dial:1] GotoIf("DAHDI/10-1", "1?dial") in new stack
-- Goto (macro-dial,s,3)
-- Executing [s@macro-dial:3] AGI("DAHDI/10-1", "dialparties.agi") in new stack
-- Launched AGI Script /var/lib/asterisk/agi-bin/dialparties.agi
dialparties.agi: Starting New Dialparties.agi
dialparties.agi: Caller ID name is '08119xxxxxx' number is '08119xxxxxx'
dialparties.agi: Methodology of ring is 'none'
-- dialparties.agi: Added extension 84 to extension map
-- dialparties.agi: Extension 84 cf is disabled
-- dialparties.agi: Extension 84 do not disturb is disabled
dialparties.agi: EXTENSION_STATE: 0 (NOT_INUSE)
-- dialparties.agi: dbset CALLTRACE/84 to 08119xxxxxx
-- dialparties.agi: Filtered ARG3: 84
-- <DAHDI/10-1>AGI Script dialparties.agi completed, returning 0
-- Executing [s@macro-dial:7] Dial("DAHDI/10-1", "SIP/84,,tm") in new stack
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
-- Called 84
-- Started music on hold, class 'default', on DAHDI/10-1
-- SIP/84-00000001 is ringing


but i completely hear no audio! but there should be some music. after few seconds my call gets dropped. but if i press answer on my ip phone i get:

-- SIP/84-00000001 answered DAHDI/10-1
-- Stopped music on hold on DAHDI/10-1

but still no audio. i think it cannot pass audio for this i hear nothing and i cannot pick up call..


any ideas what is wrong?

thanks
8 years 1 month ago #7072 by svolta
Hi,
Did it only span 4 got this issue? Did you try swap the ISDN line 4 with the others?
8 years 1 month ago #7074 by gerapcik
you are right.
i have connected to span 1 and seems to be working.
why doesnt work on span4? what's the difference?

and what is strange on span1 i have signalling = bri_cpe


8 years 1 month ago #7075 by svolta
Hi,
Please send ssh to me, I should check it! My Email: This email address is being protected from spambots. You need JavaScript enabled to view it.
8 years 1 month ago #7076 by Joe.Yung
Hi,

Try to replace signalling's value on span 4 by bri_cpe.

8 years 1 month ago #7084 by gerapcik
i have tried to use signalling = bri_cpe on span 4, but in this way i have no signal in. on CLI i have no information about incomming call.
Time to create page: 0.032 seconds
Powered by Kunena Forum