keywords:pbx ip pbx voip gateway gsm gateway

× Questions about B100/200/400/800 ISDN BRI Cards

B400P in PMP L1 down L2 down

9 years 5 months ago #5639 by alfil2k
Hi guys,

We have a B400P on my asterisk box (mith misd 1.1.9 on elastix distribution 1.6.14), connected on port 1 with my provider, and on port 2 and 3 we have gsm gateways. The gateways are working correctly in PMP, L2 is down L1 is up, and when I a make a call the L2 goes UP. That's fine, the call is OK.

The problem is on port 1, If i make a call to this line, L1 goes UP and L2 too, but the call is drooped. I call again and in this case the call is OK. In a minutes, I can see:
P[ 1] MGMT: SSTATUS: L2_RELEASED
P[ 1] MGMT: SSTATUS: L1_DEACTIVATED

Other problem on port1 is that we have noise on the call.

Here is mi misdn.conf:

[general]
misdn_init=/etc/mISDN.conf
debug=3
ntdebugflags=0
ntdebugfile=/var/log/misdn-nt.log
ntkeepcalls=yes
tracefile=/var/log/asterisk/misdn.log
bridging=no
l1watcher_timeout=0
stop_tone_after_first_digit=yes
append_digits2exten=yes
dynamic_crypt=no
crypt_prefix=**
crypt_keys=test,muh
[default]
context=misdn
language=es
musicclass=default
senddtmf=yes
far_alerting=no
allowed_bearers=all
nationalprefix=0
internationalprefix=00
rxgain=0
txgain=0
te_choose_channel=no
pmp_l1_check=no
reject_cause=16
need_more_infos=no
nttimeout=no
method=standard
overlapdial=yes
dialplan=0
localdialplan=0
cpndialplan=0
early_bconnect=no
incoming_early_audio=no
nodialtone=no
callgroup=1
pickupgroup=1
presentation=-1
screen=-1
echocancel=yes
echotraining=no
jitterbuffer=4000
jitterbuffer_upper_threshold=0
hdlc=no
max_incoming=-1
max_outgoing=-1
[intern]
[internPP]

[first_extern]
[rdsi]
ports=1,2,3
context=from-pstn
echocancel=no
msns=*
[ocultos]
ports=2
context=from-pstn
echocancel=yes
msns=*

Here is mISDN.conf:

<?xml version="1.0"?>
<!--
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Card Type: BN2S0, BN4S0, BN8S0
Card Attributes: ulaw=(yes|no), dtmf=(yes|no), pcm_slave=(yes|no),
ignore_pcm_frameclock=(yes|no), rxclock=(yes|no),
crystalclock=(yes|no), watchdog=(yes|no)
Port Attributes: mode=(te|nt), link=(ptp|ptmp), master-clock=(yes|no),
capi=(yes|no)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Card Type: BN2E1
Card Attributes: ulaw=(yes|no), dtmf=(yes|no), pcm_slave=(yes|no),
ignore_pcm_frameclock=(yes|no), rxclock=(yes|no),
crystalclock=(yes|no), watchdog=(yes|no)
Port Attributes: mode=(te|nt), link=(ptp|ptmp), optical=(yes|no), los=(yes|no),
ais=(yes|no), slip=(yes|no), nocrc4=(yes|no), capi=(yes|no)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Card Type: hfcmulti, avmfritz, w6692pci
Port Attributes: mode=(te|nt), link=(ptp|ptmp), capi=(yes|no)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Module: hfcmulti
Options: poll=<number>, pcm=<number>, debug=<number>, timer=(yes|no)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Module: hfcsusb
Options: debug=<number> poll=<number>
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Module: xhfc
Options: debug=<number>
Port Attributes: mode=(te|nt), link=(ptp|ptmp), line=(s0|up) capi=(yes|no)
lineloop_b1=(yes|no) lineloop_b2=(yes|no), lineloop_d=(yes|no)
polx=(yes|no)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Module: mISDN_dsp
Options: debug=<number>, options=<number>, poll=<number>,
dtmfthreshold=<number>
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
-->
<mISDNconf>
<module poll="128" debug="0" timer="no">hfcmulti</module>
<module debug="0" options="0">mISDN_dsp</module>
<devnode user="asterisk" group="asterisk" mode="660">mISDN</devnode>
<card type="BN4S0" ulaw="yes">
<port mode="te" link="ptmp">1</port>
<port mode="te" link="ptmp">2</port>
<port mode="te" link="ptmp">3</port>
<port mode="te" link="ptmp">4</port>
</card>
</mISDNconf>


any idea?

Thanks in advance.
Pablo:)
9 years 5 months ago #5677 by alfil2k
Hi all,

any answer?

Pablo
Time to create page: 0.024 seconds
Powered by Kunena Forum