× Questions about B100/200/400/800 ISDN BRI Cards

B200P NT chan not working

7 years 7 months ago #7386 by leon.sinko
HI,

I have

DAHDI Version: 2.4.1.2 from openvox, libpri,asterisk 1.8.7, freepbx 2.9.0.7

B200P - 1 port TE , 2 port NT

ERROR[2682]: chan_dahdi.c:13973 dahdi_pri_error: PRI Span: 3 Unable to receive TEI from network in state 3(Establish awaiting TEI)!

on port 2 NT phone not have signal. light is green, have power for phone


dahdi show channels
Chan Extension Context Language MOH Interpret Blocked State
pseudo default default In Service
1 from-pstn default In Service
2 from-internal default In Service
3 from-internal default In Service
4 from-internal default In Service
5 from-internal default In Service
6 from-internal default In Service
7 from-internal default In Service
8 from-internal default In Service
9 from-pstn default In Service
10 from-pstn default In Service
12 from-internal default In Service
13 from-internal default In Service


; Span 2: B4/0/1 "B4XXP (PCI) Card 0 Span 1"
group=0,12
context=from-pstn
switchtype = euroisdn
signalling = bri_cpe_ptmp
channel => 9-10
context = default
group = 63
; Span 3: B4/0/2 "B4XXP (PCI) Card 0 Span 2"
group=0,13
context=from-internal
overlapdial=yes
switchtype = euroisdn
signalling = bri_net_ptmp
channel => 12-13
context = default
group = 63



Requested transfer capability: 0x00 - SPEECH
-- Called DAHDI/i3/51
-- Span 3: Channel 0/1 got hangup, cause 18
-- Hungup 'DAHDI/i3/51-2'
== Everyone is busy/congested at this time (1:0/0/1)
-- Executing [s@macro-dial-one:43] ExecIf("SIP/2881-00000003", "0?Set(DIALSTATUS=)") in new stack
-- Executing [s@macro-dial-one:44] GosubIf("SIP/2881-00000003", "0?s-CHANUNAVAIL,1") in new stack
-- Executing [s@macro-dial-one:45] MacroExit("SIP/2881-00000003", "") in new stack
-- Executing [s@macro-exten-vm:8] GotoIf("SIP/2881-00000003", "0?exit") in new stack
-- Executing [s@macro-exten-vm:9] Set("SIP/2881-00000003", "SV_DIALSTATUS=CHANUNAVAIL") in new stack
-- Executing [s@macro-exten-vm:10] GosubIf("SIP/2881-00000003", "0?docfu,1") in new stack
-- Executing [s@macro-exten-vm:11] GosubIf("SIP/2881-00000003", "0?docfb,1") in new stack
-- Executing [s@macro-exten-vm:12] Set("SIP/2881-00000003", "DIALSTATUS=CHANUNAVAIL") in new stack
-- Executing [s@macro-exten-vm:13] ExecIf("SIP/2881-00000003", "0?MacroExit()") in new stack
-- Executing [s@macro-exten-vm:14] GotoIf("SIP/2881-00000003", "1?s-CHANUNAVAIL,1") in new stack
-- Goto (macro-exten-vm,s-CHANUNAVAIL,1)
-- Executing [s-CHANUNAVAIL@macro-exten-vm:1] GotoIf("SIP/2881-00000003", "0?exit,1") in new stack
-- Executing [s-CHANUNAVAIL@macro-exten-vm:2] PlayTones("SIP/2881-00000003", "congestion") in new stack
-- Executing [s-CHANUNAVAIL@macro-exten-vm:3] Congestion("SIP/2881-00000003", "10") in new stack
== Spawn extension (macro-exten-vm, s-CHANUNAVAIL, 3) exited non-zero on 'SIP/2881-00000003' in macro 'exten-vm'
== Spawn extension (from-internal, 51, 2) exited non-zero on 'SIP/2881-00000003'
-- Executing [h@from-internal:1] Hangup("SIP/2881-00000003", "") in new stack
== Spawn extension (from-internal, h, 1) exited non-zero on 'SIP/2881-00000003'

greatings from slovenija

leon
Attachments:
7 years 7 months ago #7387 by tim.june
1. You have 3 jumpers to set up, make sure the settings is right.

2. The light is green means the driver for NT is OK, check it from the asterisk console: pri show spans
PRI span 3/0: Up, Active
if the spans is up, means the NT is working fine. You need to check your FreePBX settings.
3. You need create an extension for your ISDN with Genernic DAHDI Device type and add two lines in the file
chan_dahdi.conf:
pridialplan=unknown
prilocaldialplan=unkown
Good Luck!

i] Last edited by tim.june at 2011-9-28 10:34 [/i

Email: This email address is being protected from spambots. You need JavaScript enabled to view it.
Skype: tim.jjune
7 years 6 months ago #7484 by leon.sinko
Hi
i instaled asterisk 1.8.5, now is working.
My isdn phone siemens sx 100 is working, but isdn eurit 33 is not working - red light on B200P.

If I connect eurit 33 on privider's isdn line is working but not on B200P ?!
7 years 6 months ago #7485 by leon.sinko
Hii instaled asterisk 1.8.5, now is working.My isdn phone siemens sx 100 is working, but isdn eurit 33 is not working - red light on B200P.If I connect eurit 33 on privider's isdn line is working but not on B200P ?!
7 years 6 months ago #7488 by tim.june
Hi,
Please make sure the 2 ports of B200P is both working fine when connecting ISDN line or siemens sx 100,
if it is confirmed, means the B200P is OK and you should check the jumper settings which should adapt the
isdn eurit 33.
About the settings please refer this manual:
http://downloads.openvox.cn/pub/manuals/V2.1/English/B100P_on_DAHDI_User_Manual.pdf

Email: This email address is being protected from spambots. You need JavaScript enabled to view it.
Skype: tim.jjune
Time to create page: 0.033 seconds
Powered by Kunena Forum